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1.

Das microWii ist ein All-In-One Flight-
Controller (FC) fur alle GréBen von
Multirotor Fluggeraten (Multicopter). Es
verflgt Uber einen Mikrokontroller, einen 3-
Achsen Kreisel (Gyroskop, kurz Gyro),
einen 3-Achsen Beschleunigungssensor
(Accelerometer, kurz Acc), einen 3-Achsen
Magnetometer (kurz Mag), sowie einen
Luftdrucksensor (Barometer, kurz Baro).

Der FC ist fur die Verwendung mit der
multiWii-Software (www.multiwii.com) von
Alexandre Debus - aka. AlexinParis -
entwickelt worden und unterstutzt alle
Flugzustédnde. Die beiden am meisten
genutzen sind dabei:

Acro = Kunstflug (der Multicopter verhalt
sich dhnlich wie ein Helikopter)

Stable = Stabiler Flug (&hnlich wie ein
koaxial Helikopter => der Multicopter fallt
immer zurlick in eine horizontale Lage).

Das microWii unterstitzt alle Multicopter-
Konfigurationen bis hin zum OKTO mit
zusatzlicher Kamerastabilisierung mittels
Servos.

Auf dem microWii wird ein Atmel AVR 8-bit
Mikrokontroller, der ATMEGA32U4
verwendet. Dieser verfugt tber 6
hochauflésende PMW Ausgange
(Steller/ESC Signal), ein On-Chip-USB
Interface (es wird somit kein FTDI Adapter
bendétigt) sowie Uiber die Mdglichkeit
verschiedene Empfangertypen auszulesen.

Bei der Entwicklung wurde bereits die
Moglichkeit des schwingungsgedampften
Einbaus bertcksichtigt und entsprechende
Dampfungselemente in das
Leiterplattendesign integriert.

Einleitung | Introduction

The microWii is an All-In-One Flight-
Controller (FC), usable for all sizes of
Multirotor helicopters. It is equipped with a
microcontroller, a 3-axis gyroscope (GYRO),
a 3-axis accelerometer (ACC), a 3-axis
magnetometer (MAG) and a barometer
(BARO).

The FC was developed for use with the
multiWii-software (www.multiwii.com) from
Alexandre Debus - aka. AlexInParis — and it
supports all flight conditions. The most
popular and well known are:

Acro = like a normal RC helicopters

Stable = like coaxial helicopters (it always
returns to a horizontal position)

Your microWii supports all multirotor setups
up to OKTO with additional camera
stabilization by use of servos..

An Atmel AVR 8-bit microcontroller (MCU),
the ATMEGA32U4, is used on the microWii.
This MCU has 6 high-resolution PWM (ESC
signal) outputs, an on-chip USB interface
(so, no need for a FTDI adapter) and the
ability to read the signals of various RX
types.

Anti vibration-mounts were an integral part
of the PCB design and already taken into
account from the beginning of the
development.


http://www.multiwii.com/
http://www.multiwii.com/
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2. Installation

2.1. Pins Anloten | Solder the pins

Zuerst sollte man sich entscheiden, welche
Anschllisse gebraucht werden. Es ist nicht
noétig alle Pins anzuldéten. So kann man
Gewicht und Arbeit sparen. Es kénnen
gerade oder gewinkelte Stiftleisten im
Raster 2.54mm verwendet werden.

First you should decide, which pins you
need. Not all pins are required to be
soldered. That way you can save some time
and weight. One can use 0.1" pinheaders,
straigth or angled.

2.2. Optionale Komponenten | Optional parts

Die Unterseite des microWii ist im
Auslieferzustand nur mit der Buchse 'X2'
(SM06B-SRSS-TB) und den Widerstanden
fur die LiPo-Spannungsteiler bestickt. Hier
kdénnen folgende Bauteile nachbestlickt
werden:

- Spektrum SAT Buchse:
X4: S3B-ZR-SM4A-TF(LF)(SN)(P)

- Treiber flir LED-Stripes bestehend aus:
U10: CAT4104V-GT3
LEDOUT: S2B-PH-SM4-TB(LF)(SN)

Diese Bauteile kdnnen uber Flyduino.net
oder im Fachhandel bezogen werden.

Eine detailierte Beschreibung erfolgt in den
jeweiligen Kapiteln dieser Anleitung.

The bottom (solder side) of the microWii is
only populated with the resistors used for
the LiPo voltage divider and the connector
'X2' (SM06B-SRSS-TB) on delivery
condition. You can mount some additional
components to increase the
functionality/ease of use of the microWii:

- Spektrum SAT connector:
X4: S3B-ZR-SM4A-TF(LF)(SN)(P)

- LED-Stripes driver, compromised of:
U10: CAT4104V-GT3
LEDOUT: S2B-PH-SM4-TB(LF)(SN)

You can purchase these components at
Flyduino.net or at your local dealer.

A detailed description follows in the
correspondent chapters in this users
manual.



2.3. Stromversorgung | Power Supply

Das microWii benétigt zwei
Stromversorgungen:

- 5V UBEC, anzuschlieBen an X3
- LiPo, anzuschlieBen an LiPo 25-4S

Die Ausgange werden immer Uber ein
Regler-BEC oder externes UBEC versorgt!

ACHTUNG: Das microWii bitte ausschlieBlich
mit 2-3S LiPos verwenden!
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Your microWii needs two power supplies:

- 5V UBEC, connected to X3
- LiPo, connected to LiPo 25-4S

The outputs were always supplied via an
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Attention: Use the microWii with 2-3S LiPos
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2.4. Empfanger anschlieBen | Connecting an RX

2.4.1.

Ein normaler 4 Kanal Empfanger ist
ausreichend. Aufgrund der
Sensorausstattung, und damit verbunden
den moglichen Flugzustanden, sind jedoch 6
Kanale empfehlenswert.

Es werden nur beim Gaspin alle 3 Kabel
(Signal, plus, minus) angeschlossen. Die
anderen Kanale brauchen nur das
Signalkabel. Dies vereinfacht den Aufbau

Standard Empfanger | Standard RX

You can use a standard RX with 4 channels.
Because of the sensors used and the
various flight modes available, a 6 channel
RX is recommended .

You only need to connect all three wires for
the throttle channel (signal and power
(+/-)). For all other channels only the signal
wires are needed. This will simplify your

und spart dariber hinaus wiederum Gewicht wiring and also save some weight.

eln.
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2.4.2. Summsignal Empfanger | PPM sum RX

Uber einen Summesignal-Empfanger kénnen With a PPM sum RX you can use up to 8
zur Zeit bis zu 8 Kanale genutzt werden. channels (at the time of writing) with only
Der Summensignal-Empfanger erfordert nur one single patch wire.

ein einzelnes Patchkabel.
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PPM Summensignal-Empfinger | PPM Sum receiver

2.4.3. Spektrum Satellite

Ein Spektrum Satellitenempfanger Ubertragt A Spektrum satellite receiver outputs all
alle Kanale des Fernsteuersenders Uber eine channels of the transmitter over a serial
serielle Schnittstelle (UART). Mit ihm interface (UART). With the use of a
kdénnen derzeit, genau wie beim Spektrum satellite you can use up to 8
Summensignalempfanger, bis zu 8 Kanale channels (as with a PPM Sum receiver). In
genutzt werden. Er ist auBerdem sehr klein addition, it is quite small and lightweight.
und leicht.

Der Satellite muss, bevor er mit dem Prior of using your Spektrum satellite with
microWii verwendet werden kann, an einem the microWii you need to bind it to a
Empfanger gebunden werden (siehe Spektrum receiver (please refer to the
Anleitung des Empfangers). receivers documentation for details).

Wie bereits unter 2.2 erwahnt, bietet das As already mentioned under paragraph 2.2,

microWii die Mdglichkeit auf der Unterseite the microWii gives you the possibility to

die Buchse 'X4' zu bestlicken, wodurch die  mount the connector 'X4' on the bottom of

Verwendung der Standard Anschlusskabel the PCB. This will allow you to use the

der Spektrum Satelliten mdglich ist. standard Spektrum satellite connection
cable.



Daten des Steckverbinders:
Hersteller: JST

Produkt: ZH-Series

Teile-Nr.: S3B-ZR-SM4A-TF(LF)(SN)(P)
Digikey-Nr.: 455-1694-1-ND

o

Details on the connector:
Manufacturer: JST

Product: ZH-series

Part-no: S3B-ZR-SM4A-TF(LF)(SN)(P)
Digikey-no: 455-1694-1-ND

y

JST ZH-Series, 3-pol.
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2.5. Steller anschlieBen | Connect the ESCs

Am microWii ist der Anschluss von bis zu 8 The microWii was designed to provide up to
Stellern sowie 5 weiteren Servos (maximal, 8 ESC connections plus up to 5 additional
abhdngig von der Konfiguration sowie der servos (maximum, but depends from the
Verwendung der On-Board Resourcen!) configuration and the on-board resources

vorgesehen.

used!).

Die dargestellten Pins entsprechen hier der The image shows the motors positions and
Motorenanordnung und Drehrichtung. spin directions.
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Anschliisse fiir Steller | ESC connections

O

N

+5U ESC BEC
GND

Servos

refer to documentation

for restraints:

A4 is used by on-board LiPo voltage monitor
D12 is used by on-board LED-driver

Anschliisse fiir Servos | Servo connections



. Drehrichtung im Uhrzeigersinn | CW

. Drehrichtung gegen den Uhrzeigersinn | CCW
: Tri
Bi

o' D

QuadX

Motoranschliisse mit Drehrichtung | Motor connections with spinning direction (picture credit
to Felix Niessen, aka ronco)



2.6. LiPo Spannungsteiler | LiPo voltage divider

Das microWii verflgt auf der Unterseite
Uber 3 Spannungsteiler welche flr 2-4 LiPos
dimensioniert sind. Wird in der multiWii
Software die LiPo-Uberwachung aktiviert
und der zum Flugakku passende
Spannungsteiler konfiguriert, so erméglicht
dies die Uberwachung des LiPos wahrend
des Fluges.

Der Spannungsteiler wird durch schlieBen
der zugehorigen Létbricken eingeschaltet.

ACHTUNG:

Obwohl ein Spannungsteiler flir 4S-LiPos
vorhanden ist sollte das microWii
ausschlieBlich mit 2-3S LiPos verwendet
werden!

Wird der Spannungsteiler verwendet steht
der Ausgang A4 nicht mehr flr Servos zur
Verfligung.

Es darf nur immer ein Spannungsteiler
eingeschaltet sein!

The microWii is equipped with 3 voltage
dividers on the bottom of the PCB. Enabling
the voltage monitor in the multiWii software
and configuring the voltage divider allows
monitoring of the LiPo voltage level during
flight.

The voltage divider needs to be enabled by
closing (soldering) the correspond solder
bridges.

ATTENTION:

Although there is a voltage divider for 4S-
LiPos available the microWii should only be
operated with 2-3S LiPos!

A4 can't be used for servos when the
voltage divider is used!

Only enable one divider at a time!

3S LiPo voltage divider
/ /—28 LiPo voltage divider
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2.7. Montage am Multirotor | Mounting on the multirotor

Bei dem Einbau des microWii ist darauf zu  When installing the microWii it is best
achten, dass es so mittig wie mdglich am placed at the center of your multicopter.
Multikopter angebracht wird.

Das Bild zeigt eine schematische The illustration depicts a schematic view of
Darstellung der Montage. the mounting.

schraube | Screw

Gummiringe | Rubber rings

microWii Montage | Mounting the microWii (picture credit to Felix Niessen, aka ronco)



2.8. Arduino IDE

Arduino (http://www.arduino.cc) ist eine

Open Source Software welche dazu
entwickelt wurde, den Umgang mit
bestimmten AVR Mikrocontrollern zu
vereinfachen.

Mit ihr kénnen Programme (Sketches) in C-
Code geschrieben und auf die Arduino-
Hardware programmiert (ge-flashed)
werden.

Der Arduino Leonardo verwendet den
gleichen Mikrokontroller wie das microWii,
weshalb der FC mit einem Leonardo
Bootloader ausgeliefert wird.

Die Leonardo-Plattform wird erst ab Version
1.0.1 unterstitzt. Es empfiehlt sich immer
die neuste Arduino Version zu verwenden.

Die Arduino IDE steht unter folgenden Link
zum Download zur Verfligung:
http://arduino.cc/en/Main/Software

Nach der Installation der Arduino IDE kann
der Treiber fur das microWii (Arduino
Leonardo Treiber) in dem
Installationsverzeichniss von Arduino unter
"drivers' gefunden werden.

Um das microWii in Arduino auszuwahlen,
wahlen Sie unter Tools — Board den
Arduino Leonardo und unter Tools — Serial
Port den installierten COM-Port.

Arduino (http://www.arduino.cc) is a open
source software that is designed to simplify
the use of some Atmel AVR
microcontrollers.

It is an integrated development
environment (IDE) that can be used to edit
C-Code (scetches) and upload them to the
target Arduino.

The micoWii comes preloaded with the
latest Arduino Leonardo bootloader since it
uses the same AVR as the Leonardo.

The Leonardo is supported with the latest
Arduino version. (1.0.1 or later). Always
use the latest release of the Arduino
software.

You can download the IDE under:
http://arduino.cc/en/Main/Software

After installing the Arduino software, you
need to install a driver for the microWii
(Arduino Leonardo Drivers) which is located
in the Arduino installation folder, in the
"drivers" subfolder.

To use the microWii you need to select the
Arduino Leonardo (Tools — Board —
Arduino Leonardo) and select its assigned
COM-port (Tools — Serial Port)

h

Al

Tools| Hilfe

Automatisch formatieren Strg+T
Sketch archivieren
Kadierung reparieren & neu laden

Serial Monitor Strg+Umschalt+M

Board
Serieller Port

»
-

rq

*

=]
i

Programmer »

Bootloader installieren

nare. b=

R

Sensars Serial

config.h defh

Arduine Uno

Arduino Duemilanove w/ ATmega328

Arduino Diecimila or Duemilanove w/ ATmegal68
Arduine Nano w/ ATmega328

Arduine Nano w/ ATmegal&8

Arduine Mega 2560 or Mega ADK

Arduino Mega (ATmegal280)

€ Arduino Leonardo

Leonardo in der Arduino IDE auswdhlen um das microWii zu verwenden | choose

Leonardo in the Arduino IDE to use the m

icroWii


http://arduino.cc/en/Main/Software
http://arduino.cc/en/Main/ArduinoBoardLeonardo
http://www.arduino.cc/
http://arduino.cc/en/Main/Software
http://arduino.cc/en/Main/ArduinoBoardLeonardo
http://www.arduino.cc/

2.9. MultiWii Firmware & upload

MultiWii (http://www.multiwii.com) ist eine
Open Source Multirotor Helikopter Software
von Alexandre Dubus (aka AlexinParis).

Das microWii wurde zwar zur Verwendung
mit dieser Software entwickelt, wobei es
selbstverstandlich auch flr eigene
Programme oder andere Projekte genutzt
werden kann.

Laden Sie die aktuellste MultiWii-Software

unter:
http://code.google.com

multiwii/downloads/list
Offnen Sie diese Datei (*.ino) in Arduino
und wechseln Sie in die Datei config.h
(vorletzter Tab rechts). Hier werden nun die
notwendigen Einstellungen zu den
Sensoren, sowie sonstigen gewtlinschten
Funktionen vorgenommen.

MultiWii (http://www.multiwii.com) is an
open source multirotor heli software by
Alexandre Dubus (aka AlexInParis).

The microWii was specifically designed for
use with the MultiWii-Software, but in can
be used with your own software for other
projects too.

Download the latest version of the MultiWii-

Software:
http://code.google.com

multiwii/downloads/list
Open the script (*.ino) with the Arduino-
Software and change to the file config.h.
You need to define the sensors and all other
features here.

MultiWii_2_1

Arduino 1.0.1

Multiwii_2_1

#define IZC_SPEED 100888l
J/#def ine TZ2C_SPEED 4@8808L

Buzzer EEPROM GPs IMU

config.h § PNdERk tinygps.h

//18kHz normal mode, this wvalue must be used for a genuine WHMP
J/48BkHz fast mode, it works only with some WHP clones

Internal iZc Pullups

f

¥ enable internal I2C pull ups (in mozt cozes it is better to uze external pullups) *7

A/Hdef ine TMTERMAL _IZC_PULLUPS

/
SRR boards and sensor definitions HHAAE AR
/

Combined IMU Boords £

J% Af wou use a specific sensor board:
pleaze submit any correction to this list.

MNote from Alex: I only own some boords, for other boards, I'm not sure, the info wos gothered vio ro forums, be coutious */

Aidtdef ine FRIMUwL
Aidtdef ine FRIMUYZ
J/#def ine FREEIMUyL
A/#def ine FREETMUWES A FreeIM) vA.3 and +8.3.1
A#def ine FREEIMUVESE /¢ FreeIMl) wA.3.5 no baro
//#def ine FREEIMUWESE_MS  // FreeIMU wB.3.5_MS
//#def ine FREEIMUwESE_BMP /' FreeIMU w8.3.5_BMP
J/#def ine FREEIMUvE4
H#def ine FREEIMUvE43
J/fdef ine MAMOWIT
Aidtdefine PIPO

J/fdef ine QUADRINO
A/#def ine (QUADRIND_Z00M

/¢ 9D0F boord from erozz

Af#def ing ALLINOME

/¢ first 9D0F+baro boord from Jussi, with HMCES43
/¢ second wersion of SDOF+boro board from Jussi, with HMCESSS
A wBll & wB.2 & wB.3 wersion of SDOF board from Fabio

/¢ FreelMU wB.4 with MPUSBEE, HMCESSSL, MSEG1101EB4
J4 some gz FREEIMUvE4 with final MPUGASA (with the right ACC scale)
/¢ the zmallest multiwii FC boszed on MPUSEEE + pro micro based proc =— confirmed by &lex

¢ full FC board S0OF+baro boord from witespy with BMPESE baro
¢ full FC board S0OF+boro boord from witespy =second edition
Ae#def ine QUADRINO_ZOOM_MS// full FC board SDOF+boro boord from witespy second edition
¢ full FC board or standalone 9DOF+baro board from CSG_EU

= confirmed by &lex
= confirmed by &lex

= confirmed by &lex

= confirmed by &lex

= confirmed by &lex

= confirmed by Alex

Um die Sensoren zu aktivieren die FreeIMUv043 auswdhlen | uncomment the FreeIMUv043

define to activate the sensors

Das microWii verwendet die gleichen
Sensoren (und Sensorwirkrichtungen) wie
die populdre FreeIMUv043.

Um die Sensoren zu aktivieren wird das
'#define FREEIMUv043' aktiviert.

The microWii uses the same sensors (and
axis orientation) as the popular
FreeIMUv043.

To activate the sensors you need to
uncomment the '#define FREEIMUv043'.


http://code.google.com/p/multiwii/downloads/list
http://www.multiwii.com/
http://code.google.com/p/multiwii/downloads/list
http://www.multiwii.com/
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MultiWii_2_1 | Arduino 1.0.1

m

£ ##def ine TEENSYZE

Sk Settings for ProMicro, Leonardo and other AtmegaZzud Boords

SRk

4

pin Layout

A oactivate this for o better pinlavout if all pins con be wused == not possible on ProMicro */

#def ine ASZU4ALLPINS

PN Setup
A oactivate all & hordware PWM outputs Motor B = D11 ond & = D13,

£

note: not possible on the sporkfun promicro {pin 11 & 13 are not broken out there)

if activated:

Motor 1-6 = 16-bit hordwore PWM

Motor 7-8 = 8-bit Softwore PWM

Servos = §-bit Software PWH

if deactivated:

Motor 1-4 = 168-bit hardwore PWM

Motor B-5 = 18-bit Software PWM

Servos = 18-bit Software PWM */
Af#def ine HWPWME

Aux 2 Pin

A% AUNZ pin on pin RBXO %/
S/H#der ine RCAUXZPINRXD

A auxZ pin on pin D17 (RELED) */
J/#def ine RCAURZPINDLY

Buzzer Pin

/% thiz moves the Buzzer pin from TX0 to DS for use with ppm sum or spectrum sat. RX

//#def ine DEBUZZER

2
(not needed i AZZU4ALLPING is active) ®/

SRR Promicro version relaoted

A

Hdefine A32U4ALLPINS' aktivieren | aktivate "#define A32U4ALLPINS'

Um den vollen Funktionsumfang des
microWii nutzen zu konnen muss noch das
'#define A32U4ALLPINS' aktiviert werden.

Jetzt kann die Konfiguration des
Multikopters (z.B. Typ, zusatzliche
Funktionen, ...) fertiggestellt werden.

Um den Sketch zu Uberprifen klicken Sie
auf

Um den Sketch auf das microWii zu
programmieren klicken Sie auf

To make use of the full potential of the
microWii you need to uncomment the
'#define A32U4ALLPINS'.

Now you're ready to complete your copter
setup (i.e. multicopter type, additional
features, ..).

To verify the sketch click on

To download the sketch to the microWii click
on
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4. Externe Sensoren und optionales Zubehor |
External sensors and optional features

4.1. Externes I2C-Interface | External I2C-Interface

Es kdnnen alle von der Software You may connect any I2C sensor to the
unterstitzten I2C Sensoren angeschlossen microWii that is supported by the software.
werden.

Da GYRO, ACC, MAG und BARO schon But as GYRO, ACC, MAG and BARO were
vorhanden sind, empfiehlt sich nur noch der present on the microWii the only addition
Anschluss eines externen I12C GPS Moduls. might be an external 12C GPS-module.
ACHTUNG: ATTENTION:
Der externe I2C-Bus des microWii ist fir The external I2C bus of the microWii may
3.3V Sensoren! only be used with 3.3V sensors!

+3.3V

GND SCL <3.3V leveD

O
o 00 o o
- O o
12C-Interface fiir externe Sensoren (3.3V Logikpegel) | I2C-interface for external sensors (3.3V
logic level)



4.2. LED-Treiber fiir LED-Stripes | LED-driver for LED-

Stripes

Auf der Unterseite des microWii kann ein
LED-Treiber 'U10' sowie die Buchse
'LEDOUT' nachbestiickt werden. Diese
Bauteile ermdglichen es - zusammen mit
einer Erganzung im MultiWii-Sketch - den
Flugzustand mittels LED-Stripes
anzuzeigen.

Daten des LED-Treibers 'U10":
Hersteller: ON-Semiconductor
Teile-Nr.: CAT4104V-GT3

Digikey-Nr.: CAT4104V-GT30STR-ND

Daten des 'LEDOUT' Steckverbinders:
Hersteller: JST

Produkt: PH-Series

Teile-Nr.: S2B-PH-SM4-TB(LF)(SN)
Digikey-Nr.: 455-1749-1-ND

The bottom of the microWii gives you the
possibility to mount an LED-driver 'U10' and
a connector 'LEDOUT'. Those components -
together with an addition to the MultiWii-
Sketch - allows to signalize the flight
condition of your multicopter via LED-
Stripes.

Details of the LED-driver 'U10':
Manufacturer: ON-Semiconductor
Part-no: CAT4104V-GT3

Digikey-no.: CAT4104V-GT30STR-ND

Details of the connector 'LEDOUT":
Manufacturer: JST

Product: PH-Series

Part-no.: S2B-PH-SM4-TB(LF)(SN)
Digikey-no.: 455-1749-1-ND

JST S2B-PH-SM4-

TB(LF)(SN)

Loten Sie die Bauteile auf die Unterseite der
Platine. Achten Sie auf richtige Orientierung
von 'U10'. Sichern Sie die 'LEDOUT'-Buchse
ggf. zusatzlich mit etwas Sekundenkleber.

0o +

Solder the components in place on the
bottom of the microWii-PCB. Please observe
for correct orientation of 'U10'. Apply some
superglue to 'LEDOUT" if needed.

+

¥

Orientierung von U0 | Orientation of U10
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1-2 closed: LEDOUT b
2-3 closed: LEDOUT b
Cathode of STATUS strip

JP4:
LEDOUT

microWii mit montiertem LED-Treiber, Spektrum Buchse und
eingeschaltetem 3S-LiPo Spannungsteiler | microWii populated with LED-
driver, Spektrum connector and 3S-LiPo voltage divider enabled

LEDOUT
Cathode of

LED-Treiber - an LEDOUT wird die Kathode der LED-Stripes
angeschlossen | LED-driver - connect the cathode of the LED-stripes to
LEDOUT



GND

RGB LED-Strip B

RGB LED-Strip am LEDOUT anschliefsen | connecting a RGB LED-strip to LEDOUT

4.2.1.

Funktionsbeschreibung LED-Treiber | functional

description of the LED-driver

Der CAT4104 ('U10") ist ein LED-Treiber der
so eingestellt wurde dass er 600mA Strom
liefern kann.

Der Treiber arbeitet als Stromsenke, weshalb

an den 'LEDOUT'-Anschluss die Kathoden
(Minus-Pol) der LED-Stripes angeschlossen
werden mussen.

Die Schaltung in der Abbildung ist lediglich
ein Vorschlag. Bei dieser Schaltung ist die

Grundfarbe von Strip A griin wahrend Strip B
rot leuchtet nachdem der LiPo angeschlossen

wurde. Uber den LED-Treiber wird nun eine
andere Farbe (rot bzw. blau) 'beigemischt'.

The CAT4104 ('U10') is a LED-driver that is
configured to supply 600maA.

The driver is working as a current sink,
that's why you need to connect the
cathodes (negative terminal) of your LED-
stripes to 'LEDOUT'-connector.

The schematic shown above is only acting
as an example. With this wiring strip A will
light up green and strip B will light up red
once the LiPos is connected. The LED-
driver now mixes a second colour into (red
respectively blue).



Es sind zwei Ansteuervarianten ftr 'U10'
vorgesehen:
» statisch, als 'STATUS-LED' analog zur
On-Board 'STATUS-LED'
* dynamisch, iber PWM durch das
'CAM-T' Signal (Anschluss D12)
angesteuert

Wird 'U10' durch eine PWM angesteuert
kdénnen - je nach Duty-Cyle der PWM -
unterschiedliche Farben dargestellt werden.
Somit kann das microWii z.B. den jeweiligen
Flugzustand durch ein andere Farbe
anzeigen.

Die Auswahl der Ansteuerung erfolgt tUber
den Lotjumper 'JP4' auf der Oberseite des
Boards.
Die mdglichen Betriebsarten sind:

» offen: 'LEDOUT' ohne Funktion

+ 1-2 verbunden: statisch

+ 2-3 verbunden: dynamisch

Damit der LED-Treiber genutzt werden kann
sind auch Anderungen/Erganzungen im
Sketch notwendig.

4.2.2.

ACHTUNG:

WIRD DIE STATISCHE FUNKTIONSWEISE
GEWAHLT, SO IST KEINE ANDERUNG IM
SKETCH NOTWENDIG!

LED-Treiber Software

The are two possible modes of operation
for 'U10":
» static, as 'STATUS-LED' like the
onboard 'STATUS-LED'
* dynamically, via PWM from the
'CAM-T' signal (connector D12)

You will get different mixed colours when
driving 'U10' dynamically via PWM -
dependant on the duty cycle of your PWM.
Because of that it is possible to use the
microWii for signalizing different flight
modes by different colour schemes.

The operation mode is selected with the
solder-jumper 'JP4' on the TOP-Side of the
PCB.
The selectable operation modes are:

» open: 'LEDOUT' has no function

e 1-2 connected (soldered): static

+ 2-3 connected (soldered):

dynamically

You need to make some changes/additions
to the multiWii-sketch in order to make use
of the LED-driver.

| LED-driver software

ATTENTION:

NO MODIFICATION OF THE SKETCH IS
NEEDED WHEN YOU CHOOSE TO USE THE
STATIC DRIVE METHOD.



5. Technische Details | Technical Details

Power Input:
* LiPo 2-3S (5-12,6V)

Power Output:
« -VCC 5V max. 100mA
« -3,3V max. 100mA

Prozessor:
* Atmel ATMEGA32U4-MU
« 16Mhz
+ 32 kB Flash
+ 2.5 kB SRAM
+ 1kB EEPROM
« Datenblatt | data sheet: http://www.atmel.com/Images/doc7766.pdf

Gyro & ACC:

InvenSense MPU-6050

Datenblatt | data sheet:
http://www.invensense.com/mems/gyro/documents/PS-MPU-6000A.pdf

MAG:

Honeywell HMC5883L-TR

Datenblatt | data sheet:
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-
documents/Defense_Brochures-documents/HMC5883L_3-
Axis_Digital_Compass_IC.pdf

BARO:

Measurement Specialities MS5611-01BA

Datenblatt | data sheet:
http://www.meas-spec.com/product/t_product.aspx?id=8501

USB Anschluss:
Mini USB

The Spektrum brand is a trademark of Horizon Hobbies USA.


http://www.meas-spec.com/product/t_product.aspx?id=8501
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www.invensense.com/mems/gyro/documents/PS-MPU-6000A.pdf
http://www.atmel.com/Images/doc7766.pdf

6. Anlage | Appendix

6.1. Schaltplan | Schematics

6.2. Bootloader programmieren | Flashing the Bootloader

Auf der Unterseite des microWii befindet sich The bottom of the microWii features a 6-

ein 6-poliger ISP-Anschluss. Uber diesen
kann der ATMEGA32U4 mit einem
Programmiergerat oder JTAG-ICE
programmiert bzw. zum Code-debugging
genutzt werden.

Der Anschluss kann aber auch dazu genutzt

werden um einen neuen Bootloader zu
programmieren - wenn es zukilnftig einen
geben sollte.

a) bendtigtes Zubehdr
+ einen weiteren Arduino (ProMini,

Nano, UNO, Duemilanove, Mega, ...).

Achtung! Beim Mega weichen die
Pinnamen von den nachfolgend
genannten ab.

* ein paar Litzen 0-a. und einen
Loétkolben

b) Wie im Bild dargestellt verdrahten

c) Den neuen Bootloader laden

Dieser wird z.b. im Forum oder auf
flyduino.com bereitgestellt sobald es eine
neue Version geben sollte.

Entpacken Sie das .ZIP-File und kopieren Sie

das .HEX-File in den Ordner

Arduinol.0.1/hardware/arduino/bootloaders/

caterina
Die bestehende Datei muss lberschreiben
werden!

Alle ausgelieferten Boards haben den
aktuellsten Bootloader!

pin ISP footprint. This can be used fot
programming the ATMEGA32U4 with an
ISP-programmer or for programming or
code debugging with a JTAG-ICE.

You can use this connector for flashing a
new bootloader too - if the need arose in
the future.

a) equipment needed
another Arduino (ProMini, Nano, UNO,

Duemilanove, Mega, ...)

Please notice that the Mega uses diferent
pinnames than those mentioned below.

A few jump wires i.e. and a soldering iron

b) wire the boards as pictured

c) flashing the new bootloader

The bootloader will be available on
flyduino.com or in the forum once a new
version is available.

Download the .ZIP-file and copy the
enclosed .HEX-file into the folder
Arduinol.0.1/hardware/arduino/bootloader
s/caterina

You must overwrite the existing file!

All microWii boards were flashed with the
latest bootloader!



d) Arduino zum ISP-Programmer machen
* verbinden Sie den Arduino (nicht das
microWii!) wie gewohnt mittels FTDI
mit Threm PC

+ 0Offnen Sie Arduino 1.0.1 (oder neuer)

+ wahlen Sie den COM-Port des FTDI
und das richtige Arduino-Board aus

+ gehen Sie auf Datei -> Beispiele ->
ArduinoISP

« den ArduinoISP-Sketch auf den
Arduino laden

Ihr Arduino kann jetzt als ISP-Programmer
flr die Atmel AVR Mikrokontroller genutzt
werden!

e) Bootloader programmieren

« Uberpriifen Sie nochmals die
Verkabelung (siehe Bild)

* Klicken Sie auf Tools -> Board ->
Arduino Leonardo
Der Leonardo (also das microWii)
muss als Board ausgewahlt sein da
Sie bei diesem Board den Bootloader
neu programmieren méchten.

» Klicken Sie auf Tools -> Programmer
-> Arduino as ISP

Damit teilen Sie der IDE mit, dass Sie

als 'Programmiergerat' einen Arduino
verwenden

« Klicken Sie auf Tools -> Bootloader
Installieren

Der Vorgang dauert einen Moment. Wenn er
beendet ist verfligt Ihr microWii tUber den
neuen Bootloader.

Anmerkung:

Es kommt vor, das Sie beim ersten Versuch
die Fehlermeldung "...not in sync..."
erhalten. Versuchen Sie den Vorgang dann
einfach nochmals (Tools -> Bootloader
Installieren).

Wenn es es nach mehreren Versuchen
immer noch nicht geht kann es helfen, die
Arduino IDE sowie Ihr Arduino-Board (als
den ISP-Programmer) neu zu starten. Wenn
die Programmierung dann immer noch nicht
funktioniert ist mit hoher Wahrscheinlichkeit

d) Using the Arduino as ISP-Programmer
* connect your Arduino (not your
microWii) via FTDI-adapter to your
PC

» open Arduino 1.0.1 (or later)

» select the COM-Port of your FTDI-
adapter and the right Arduino-Board

» click on File -> Examples ->
ArduinoISP

« download the ArduinoISP-Sketch to
your Arduino-Board

Now your Arduino is ready for use as an
ISP-Programmer for Atmel AVR
microcontrollers!

e) flashing the new bootloader

» Check all wires (refer to picture
below)

e Click on Tools -> Board -> Arduino
Leonardo
You need to select the Leaonardo
(that meens your microWii) here
since you want to flash a new
bootloader to it

* Click on Tools -> Programmer ->
Arduino as ISP
This configures the IDE for use with
an Arduino that is programmed with
the ArduinoISP-Sketch

* Click on Tools -> Install Bootloader

Flashing the bootloader takes a few
moments. Once finished your microWii
features the latest bootloader.

Remarks:
It is possible that you get an error
message "...not in sync..." . In this case

please retry flashing the bootloader (Tools
-> Install Bootloader).

If flashing fails after several attempts one
possible solution is to power-cycle your
Arduino-Board (the one you're using as an
ISP-Programmer) and to restart the
Arduino IDE. If flashing still fails you
should check your wiring again and restart



eine Leitung falsch verbunden. Uberpriifen  the process.
Sie bitte die Verkabelung und wiederholen
sie gegebenenfalls den Vorgang.

Pro Mini MicroWii
VCC +5V
GND GND
10 RESET
11 MOSI
12 MISO
13 SCLK
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ProMini als ISP- Programmer | Using a ProMini as ISP Programmer (plcture credzt to Felix
Niessen, aka ronco)



6.3. 4S-LiPo Modifikation | 4S-LiPo modification

Das microWii ist nur fir den Betrieb mit 2S5-

bis 3S-LiPos spezifiziert.
Nachstehend finden Sie Informationen wie

Sie Ihr microWii fir den sicheren Betrieb an

4S-LiPos modifizieren kénnen.

ACHTUNG!
DER NACHSTEHEND GEZEIGT UMBAU
ERFOLGT AUF EIGENE VERANTWORTUNG!

ALLE SPANNUNGSQUELLEN (LiPo, UBEC,
REGLER, ..) UNBEDINGT ABKLEMMEN!

a) bendtigtes Zubehér
» Skalpell oder ahnlich Scharfe Klinge

(z.B. Rasierklinge)

» ein Stlckchen isolierten Draht

» externes 5V UBEC (im Lieferumfang
des microWii enthalten; muss nach
dem Umbau an 'X3' angeschlossen
werden)

b) Beschreibung des Umbaus

Der Umbau schaltet den On-Board 5V Regler
'U3' dauerhaft ab indem 3 Leiterbahnen auf

der microWii-Platine unterbrochen

(durchgeschnitten) werden (die drei Schnitte

sind im Bild als Doppellinien dargestellt ->
lieber 2x an jedem Anschluss schneiden!).

Dann wird eine Drahtbricke - wie im Bild
dargestellt - von C3 auf C1 - gelodtet. Bitte
darauf achten dass ein isolierter Draht

verwendet wird! Dadurch werden die 5V des

UBEC (an 'X3' angeschlossen) als
Eingangsspannung fur den 3.3V Regler 'U4'
verwendet. Durch die niedrigere

Eingangsspannung ist die Verlustleistung im

Regler 'U4' geringer und ein 4S-Betrieb
problemlos maéglich.

c) Uberpriifung des Umbaus

Um sicherzustellen dass die Leiterbahnen
richtig durchtrennt worden sind unbedingt
mit einen Widerstandsmesser vom Plus-

Anschluss des 'X5' (+ des LiP025-4S) gegen

die beiden Anschliisse von U3 messen.

HIER DARF KEINE VERBINDUNG MEHR
BESTEHEN!!!!

The microWii is rated for use with 25-3S
LiPos.

This chapter will give you some information
on how to modify your microWii for save
use with 4S-LiPos.

ATTENTION!
THIS MODIFICATION IS AT YOUR OWN
RISK!

YOU NEED TO ENSURE THAT ALL VOLTAGE
SOURCES (LiPo, UBEC, ESC, ..) WERE
DISCONNECTED!

a) equipment needed

» Scalpel or comparable sharp knife
(i.e. razor blade)

» a small piece of isolated wire

» external 5V UBEC (within the cope
of supply; needs to be connected to
'X3"' when the modification was
made)

b) description of the modification

This modification permanently disconnects
the on-board 5V LDO 'U3' by severing 3
traces on the microWii-PCB (the cuttings
were shown on the illustration by double
lines)

Solder the wire as shown from C3 to C1.
Please ensure to use an isolated piece of
wire! Now the 5V coming from the UBEC
(connected to 'X3")serves as input voltage
for the 3.3V LDO 'U4'. The power
dissipation of 'U4' is now less because of
the lower input voltage. This will allow save
operation with 4S-LiPos.

c) Inspecting the modification

To ensure that the traces were
disconnected use your ohmmeter and
measure the resistance between the '+' pin
of 'X5' and the two lower pins of U3.

THERE MUST BE NO CONNECTON HERE -
THUS THE RESISTANCE IS INFINITE!



Nochmals prifen dass keine Kurzschlisse Re-check your soldering for shorts (i.e. by
entstanden sind (z.B. durch Létzinn). solder).

Dann den UBEC wieder an 'X3"' anschlieBen  Now connect the UBEC to 'X3' and connect
und mit einer Spannungsquelle (idealerweise it to a voltage supply (a current limited

einem Netzteil mit Strombegrenzung) powersupply would be best). Use your
verbinden. Mit einem Multimeter Uberplifen  multimeter and check the 5V supply (i.e.
ob die 5V vorhanden sind (z.B. an den on the RX-connector). Now check the 3.3V
Empfanger-Anschlissen). Dann mit dem supply (i.e. on the 'T2CEXTLV'-connector -
Multimeter nachmessen ob die 3.3V the external I12C interface).

vorhanden sind (z.B. am 'I2CEXTLV' - dem

externen I2C-Interface).

Sind beide Spannungen vorhanden kann der If both voltages were o.k. You can start to
Multicopter wieder/weiter montiert werden. re-/assemble your multicopter again.

Ihr microWii kann kinftig mit einem LiPo Now your microWii is save for operation
>3S betreiben werden, nur limitiert durch with LiPos > 3S, only limited by the supply
den Eingangsspannungsbereich des externen voltage range of the external UBEC.

UBEC.

Der LiPo-Anschluss 'X5' kann nach dem hier The LiPo-connector 'X5' can still be used for
gezeigten Umbau immer noch flr die LiPo- monitoring the LiPo-voltage up to 4S
Uberwachung bis 4S genutzt werden (remember to activate the corresponding
(Spannungsteiler einschalten). voltage divider).

Isoliertes Drahtstlck
Isolated jump uwire

A B N B B B B N B B N N B N N B N 3 B B N B B B B N B B B B B B B N B B N

microWii 4S-LiPo Umbau | microWii 4S-LiPo modification



Vorbehalt | Disclaimer:

Dieses Dokument wurde als Referenz fuer das
“microWii” erstellt, und erhebt keinerlei Anspruch
auf Korrektheit und/oder Vollstandigkeit. Beim
Umgang mit elektrischen und elektronischen
Bauelementen sollten stets die ensprechenden
Vorsichtsmassnahmen getroffen werden.

Die MultiWii Software wurde unter the GPL
veroffentlicht.

This is a reference document for the 'microWii'
flight controller and does not claim to be correct
nor complete. When handling electrical or
electronic components please always use safe
practices.

The MultiWii software was released under the GPL
license.

\
AT

Revisions:
v0.1:

v0.2: updated and reviewed edition - 08/27/12
v0.3: updated revision - for internal use only
v0.4: information on LED-driver added - 09/03/12

initial release based on the nanoWii manual - WORK IN PROGRESS!!
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