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1.  Einleitung | Introduction

Das microWii ist ein All-In-One Flight-
Controller (FC) für alle Größen von 
Multirotor Fluggeräten (Multicopter). Es 
verfügt über einen Mikrokontroller, einen 3-
Achsen Kreisel (Gyroskop, kurz Gyro), 
einen 3-Achsen Beschleunigungssensor 
(Accelerometer, kurz Acc), einen 3-Achsen 
Magnetometer (kurz Mag), sowie einen 
Luftdrucksensor (Barometer, kurz Baro).

Der FC ist für die Verwendung mit der 
multiWii-Software (www.multiwii.com) von 
Alexandre Debus – aka. AlexinParis – 
entwickelt worden und unterstützt alle 
Flugzustände. Die beiden am meisten 
genutzen sind dabei:

Acro = Kunstflug (der Multicopter verhält 
sich ähnlich wie ein Helikopter)

Stable = Stabiler Flug (ähnlich wie ein 
koaxial Helikopter => der Multicopter fällt 
immer zurück in eine horizontale Lage).

Das microWii unterstützt alle Multicopter-
Konfigurationen bis hin zum OKTO mit 
zusätzlicher Kamerastabilisierung mittels 
Servos.

Auf dem microWii wird ein Atmel AVR 8-bit 
Mikrokontroller, der ATMEGA32U4 
verwendet. Dieser verfügt über 6 
hochauflösende PMW Ausgänge 
(Steller/ESC Signal), ein On-Chip-USB 
Interface (es wird somit kein FTDI Adapter 
benötigt) sowie über die Möglichkeit 
verschiedene Empfängertypen auszulesen.

Bei der Entwicklung wurde bereits die 
Möglichkeit des schwingungsgedämpften 
Einbaus berücksichtigt und entsprechende 
Dämpfungselemente in das 
Leiterplattendesign integriert.

The microWii is an All-In-One Flight-
Controller (FC), usable for all sizes of 
Multirotor helicopters. It is equipped with a 
microcontroller, a 3-axis gyroscope (GYRO), 
a 3-axis accelerometer (ACC), a 3-axis 
magnetometer (MAG) and a barometer 
(BARO).

The FC was developed for use with the 
multiWii-software (www.multiwii.com) from 
Alexandre Debus – aka. AlexInParis – and it 
supports all flight conditions. The most 
popular and well known are:

Acro = like a normal RC helicopters

Stable = like coaxial helicopters (it always 
returns to a horizontal position)

Your microWii supports all multirotor setups 
up to OKTO with additional camera 
stabilization by use of servos..

An Atmel AVR 8-bit microcontroller (MCU), 
the ATMEGA32U4, is used on the microWii. 
This MCU has 6 high-resolution PWM (ESC 
signal) outputs, an on-chip USB interface 
(so, no need for a FTDI adapter) and the 
ability to read the signals of various RX 
types.

Anti vibration-mounts were an integral part 
of the PCB design and already taken into 
account from the beginning of the 
development.

http://www.multiwii.com/
http://www.multiwii.com/


microWii Oberseite in Flugrichtung (oben) | Top view in 
flight direction (top)

microWii Unterseite | Bottom view



2.  Installation

 2.1.  Pins Anlöten | Solder the pins

Zuerst sollte man sich entscheiden, welche 
Anschlüsse gebraucht werden. Es ist nicht 
nötig alle Pins anzulöten. So kann man 
Gewicht und Arbeit sparen. Es können 
gerade oder gewinkelte Stiftleisten im 
Raster 2.54mm verwendet werden.

First you should decide, which pins you 
need. Not all pins are required to be 
soldered. That way you can save some time 
and weight. One can use 0.1'' pinheaders, 
straigth or angled. 

 2.2.  Optionale Komponenten | Optional parts

Die Unterseite des microWii ist im 
Auslieferzustand nur mit der Buchse 'X2' 
(SM06B-SRSS-TB) und den Widerständen 
für die LiPo-Spannungsteiler bestückt. Hier 
können folgende Bauteile nachbestückt 
werden:

- Spektrum SAT Buchse:
     X4: S3B-ZR-SM4A-TF(LF)(SN)(P)

- Treiber für LED-Stripes bestehend aus:
     U10: CAT4104V-GT3
     LEDOUT: S2B-PH-SM4-TB(LF)(SN)

Diese Bauteile können über Flyduino.net 
oder im Fachhandel bezogen werden.
Eine detailierte Beschreibung erfolgt in den 
jeweiligen Kapiteln dieser Anleitung. 

The bottom (solder side) of the microWii is 
only populated with the resistors used for 
the LiPo voltage divider and the connector 
'X2' (SM06B-SRSS-TB) on delivery 
condition. You can mount some additional 
components to increase the 
functionality/ease of use of the microWii: 

- Spektrum SAT connector:
     X4: S3B-ZR-SM4A-TF(LF)(SN)(P)

- LED-Stripes driver, compromised of:
     U10: CAT4104V-GT3
     LEDOUT: S2B-PH-SM4-TB(LF)(SN)

You can purchase these components at 
Flyduino.net or at your local dealer.
A detailed description follows in the 
correspondent chapters in this users 
manual.



 2.3.  Stromversorgung | Power Supply

Das microWii benötigt zwei 
Stromversorgungen:

- 5V UBEC, anzuschließen an X3
- LiPo, anzuschließen an LiPo 2S-4S

Die Ausgänge werden immer über ein 
Regler-BEC oder externes UBEC versorgt!

ACHTUNG: Das microWii bitte ausschließlich 
mit 2-3S LiPos verwenden!

Your microWii needs two power supplies:

- 5V UBEC, connected to X3
- LiPo, connected to LiPo 2S-4S

The outputs were always supplied via an 
ESC BEC or an external UBEC!

Attention: Use the microWii with 2-3S LiPos 
only!

Spannungsversorgung | VCC connections



 2.4.  Empfänger anschließen | Connecting an RX

 2.4.1.  Standard Empfänger | Standard RX

Ein normaler 4 Kanal Empfänger ist 
ausreichend. Aufgrund der 
Sensorausstattung, und damit verbunden 
den möglichen Flugzuständen, sind jedoch 6 
Kanäle empfehlenswert.

Es werden nur beim Gaspin alle 3 Kabel 
(Signal, plus, minus) angeschlossen. Die 
anderen Kanäle brauchen nur das 
Signalkabel. Dies vereinfacht den Aufbau 
und spart darüber hinaus wiederum Gewicht 
ein.

You can use a standard RX with 4 channels. 
Because of the sensors used and the 
various flight modes available, a 6 channel 
RX is recommended .

You only need to connect all three wires for 
the throttle channel (signal and power 
(+/-)). For all other channels only the signal 
wires are needed. This will simplify your 
wiring and also save some weight.

6-Kanal Empfänger | 6-channel receiver



 2.4.2.  Summsignal Empfänger | PPM sum RX

Über einen Summsignal-Empfänger können
zur Zeit bis zu 8 Kanäle genutzt werden.
Der Summensignal-Empfänger erfordert nur 
ein einzelnes Patchkabel.

With a PPM sum RX you can use up to 8 
channels (at the time of writing) with only 
one single patch wire.

 2.4.3.  Spektrum Satellite

Ein Spektrum Satellitenempfänger überträgt 
alle Kanäle des Fernsteuersenders über eine 
serielle Schnittstelle (UART). Mit ihm 
können derzeit, genau wie beim 
Summensignalempfänger, bis zu 8 Kanäle 
genutzt werden. Er ist außerdem sehr klein 
und leicht.

Der Satellite muss, bevor er mit dem 
microWii verwendet werden kann, an einem 
Empfänger gebunden werden (siehe 
Anleitung des Empfängers).

Wie bereits unter 2.2 erwähnt, bietet das 
microWii die Möglichkeit auf der Unterseite 
die Buchse 'X4' zu bestücken, wodurch die 
Verwendung der Standard Anschlusskabel 
der Spektrum Satelliten möglich ist.

A Spektrum satellite receiver outputs all 
channels of the transmitter over a serial 
interface (UART). With the use of a 
Spektrum satellite you can use up to 8 
channels (as with a PPM Sum receiver). In 
addition, it is quite small and lightweight.

Prior of using your Spektrum satellite with 
the microWii you need to bind it to a 
Spektrum receiver (please refer to the 
receivers documentation for details).

As already mentioned under paragraph 2.2, 
the microWii gives you the possibility to 
mount the connector 'X4' on the bottom of 
the PCB. This will allow you to use the 
standard Spektrum satellite connection 
cable.

PPM Summensignal-Empfänger | PPM Sum receiver



Daten des Steckverbinders:
Hersteller: JST
Produkt: ZH-Series
Teile-Nr.: S3B-ZR-SM4A-TF(LF)(SN)(P)
Digikey-Nr.: 455-1694-1-ND

Details on the connector:
Manufacturer: JST
Product: ZH-series
Part-no: S3B-ZR-SM4A-TF(LF)(SN)(P)
Digikey-no: 455-1694-1-ND

Spektrum Satellitenempfänger | Spektrum Satellite receiver

JST ZH-Series, 3-pol.



 2.5.  Steller anschließen | Connect the ESCs

Am microWii ist der Anschluss von bis zu 8 
Stellern sowie 5 weiteren Servos (maximal, 
abhängig von der Konfiguration sowie der 
Verwendung der On-Board Resourcen!) 
vorgesehen. 

Die dargestellten Pins entsprechen hier der 
Motorenanordnung und Drehrichtung.

The microWii was designed to provide up to 
8 ESC connections plus up to 5 additional 
servos (maximum, but depends from the 
configuration and the on-board resources 
used!). 

The image shows the motors positions and 
spin directions.

Anschlüsse für Steller | ESC connections

Anschlüsse für Servos | Servo connections



Motoranschlüsse mit Drehrichtung | Motor connections with spinning direction (picture credit 
to Felix Niessen, aka ronco)



 2.6.  LiPo Spannungsteiler | LiPo voltage divider

Das microWii verfügt auf der Unterseite 
über 3 Spannungsteiler welche für 2-4 LiPos 
dimensioniert sind. Wird in der multiWii 
Software die LiPo-Überwachung aktiviert 
und der zum Flugakku passende 
Spannungsteiler konfiguriert, so ermöglicht 
dies die Überwachung des LiPos während 
des Fluges.
Der Spannungsteiler wird durch schließen 
der zugehörigen Lötbrücken eingeschaltet.

ACHTUNG: 
Obwohl ein Spannungsteiler für 4S-LiPos 
vorhanden ist sollte das microWii 
ausschließlich mit 2-3S LiPos verwendet 
werden!
Wird der Spannungsteiler verwendet steht 
der Ausgang A4 nicht mehr für Servos zur 
Verfügung. 
Es darf nur immer ein Spannungsteiler 
eingeschaltet sein!

The microWii is equipped with 3 voltage 
dividers on the bottom of the PCB. Enabling 
the voltage monitor in the multiWii software 
and configuring the voltage divider allows 
monitoring of the LiPo voltage level during 
flight.

The voltage divider needs to be enabled by 
closing (soldering) the correspond solder 
bridges.

ATTENTION: 
Although there is a voltage divider for 4S-
LiPos available the microWii should only be 
operated with 2-3S LiPos!

A4 can't be used for servos when the 
voltage divider is used!

Only enable one divider at a time!

LiPo Spannungsteiler | LiPo voltage dividers



 2.7.  Montage am Multirotor |  Mounting on the multirotor

Bei dem Einbau des microWii ist darauf zu 
achten, dass es so mittig wie möglich am 
Multikopter angebracht wird.
Das Bild zeigt eine schematische 
Darstellung der Montage.

When installing the microWii it is best 
placed at the center of your multicopter.

The illustration depicts a schematic view of 
the mounting.

microWii Montage | Mounting the microWii (picture credit to Felix Niessen, aka ronco)



 2.8.  Arduino IDE

Arduino (http://www.arduino.cc) ist eine 
Open Source Software welche dazu 
entwickelt wurde, den Umgang mit 
bestimmten AVR Mikrocontrollern zu 
vereinfachen.
Mit ihr können Programme (Sketches) in C-
Code geschrieben und auf die Arduino-
Hardware programmiert (ge-flashed) 
werden.
Der Arduino Leonardo verwendet den 
gleichen Mikrokontroller wie das microWii, 
weshalb der FC mit einem Leonardo 
Bootloader ausgeliefert wird.

Die Leonardo-Plattform wird erst ab Version 
1.0.1 unterstützt. Es empfiehlt sich immer 
die neuste Arduino Version zu verwenden.

Die Arduino IDE steht unter folgenden Link 
zum Download zur Verfügung:  
http://arduino.cc/en/Main/Software 

Nach der Installation der Arduino IDE kann 
der Treiber für das microWii (Arduino 
Leonardo Treiber) in dem 
Installationsverzeichniss von Arduino unter 
''drivers'' gefunden werden.

Um das microWii in Arduino auszuwählen, 
wählen Sie unter Tools → Board den Arduino 
Leonardo und unter Tools →  Serial Port den 
installierten COM-Port.

Arduino (http://www.arduino.cc) is a open 
source software that is designed to simplify 
the use of some Atmel AVR 
microcontrollers.

It is an integrated development 
environment (IDE) that can be used to edit 
C-Code (scetches) and upload them to the 
target Arduino.
The micoWii comes preloaded with the 
latest Arduino Leonardo bootloader since it 
uses the same AVR as the Leonardo.

The Leonardo is supported with the latest 
Arduino version. (1.0.1 or later). Always 
use the latest release of the Arduino 
software.

You can download the IDE under: 
http://arduino.cc/en/Main/Software 

After installing the Arduino software, you 
need to install a driver for the microWii 
(Arduino Leonardo Drivers) which is located 
in the Arduino installation folder, in the 
''drivers'' subfolder.

To use the microWii you need to select the 
Arduino Leonardo (Tools → Board → Arduino 
Leonardo) and select its assigned  COM-port 
(Tools → Serial Port)

Leonardo in der Arduino IDE auswählen um das microWii zu verwenden | choose 
Leonardo in the Arduino IDE to use the microWii

http://arduino.cc/en/Main/Software
http://arduino.cc/en/Main/ArduinoBoardLeonardo
http://www.arduino.cc/
http://arduino.cc/en/Main/Software
http://arduino.cc/en/Main/ArduinoBoardLeonardo
http://www.arduino.cc/


 2.9.  MultiWii Firmware & upload

 2.9.1.  Allgemeine Einstellungen | General settings

MultiWii (http://www.multiwii.com) ist eine 
Open Source Multirotor Helikopter Software 
von Alexandre Dubus (aka AlexinParis).

Das microWii wurde zwar zur Verwendung 
mit dieser Software entwickelt, wobei es 
selbstverständlich auch für eigene 
Programme oder andere Projekte genutzt 
werden kann.

Laden Sie die aktuellste MultiWii-Software 
unter:
http://code.google.com/p/multiwii/downloads/list 

Öffnen Sie diese Datei (*.ino) in Arduino 
und wechseln Sie in die Datei config.h 
(vorletzter Tab rechts). Hier werden nun die 
notwendigen Einstellungen zu den 
Sensoren, sowie sonstigen gewünschten 
Funktionen vorgenommen.

Das microWii verwendet die gleichen 
Sensoren (und Sensorwirkrichtungen) wie 
die populäre FreeIMUv043. 
Um die Sensoren zu aktivieren wird das
 #define FREEIMUv043 aktiviert.

MultiWii (http://www.multiwii.com) is an 
open source multirotor heli software by 
Alexandre Dubus (aka AlexInParis).

The microWii was specifically designed for 
use with the MultiWii-Software, but in can 
be used with your own software for other 
projects too.

Download the latest version of the MultiWii-
Software:
http://code.google.com/p/multiwii/downloads/list 

Open the script (*.ino) with the Arduino-
Software and change to the file config.h. 
You need to define the sensors and all other 
features here.

The microWii uses the same sensors (and 
axis orientation) as the popular 
FreeIMUv043.
To activate the sensors you need to 
uncomment the #define FREEIMUv043.

Um die Sensoren zu aktivieren die FreeIMUv043 auswählen | uncomment the FreeIMUv043 
define to activate the sensors

http://code.google.com/p/multiwii/downloads/list
http://www.multiwii.com/
http://code.google.com/p/multiwii/downloads/list
http://www.multiwii.com/


Um den vollen Funktionsumfang des 
microWii nutzen zu können muss noch das 
'#define A32U4ALLPINS' aktiviert werden.

Jetzt kann die Konfiguration des 
Multikopters (z.B. Typ, zusätzliche 
Funktionen, …) fertiggestellt werden.

Um den Sketch zu überprüfen klicken Sie 
auf 

Um den Sketch auf das microWii zu 
programmieren klicken Sie auf

To make use of the full potential of the 
microWii you need to uncomment the 
'#define A32U4ALLPINS'.

Now you're ready to complete your copter 
setup (i.e. multicopter type, additional 
features, ..).

To verify the sketch click on

To download the sketch to the microWii click 
on

'#define A32U4ALLPINS' aktivieren | aktivate '#define A32U4ALLPINS'



 2.9.2.  Spezielle Einstellungen | Special settings

Um AUX2 bei einen Standard 6-Kanal 
Empfänger (RX) verwenden zu können 
muss zusätzlich das

#define RCAUX2PIND17 

auskommentiert werden.

To make use of AUX2 with a standard 6-
channel receiver (RX) you need to un-
commend the

#define RCAUX2PIND17

Um einen Spektrum Satelliten-Empfänger zu 
verwenden muss dieser im Code aktiviert 
werden indem

#define SERIAL_SUM_PPM

und 

#define SPEKTRUM 2048

auskommentiert werden.

For using a Spektrum satellite receiver you need 
to activate (un-commend)  the

#define SERIAL_SUM_PPM

and

#define SPEKTRUM 2048

in the sketch.

Zusätzliche Änderung bei Verwendung von AUX2 mit einem 6-Kanal RX | additional change when 
using AUX2 with an 6-channel receiver



Hierbei gilt zu beachten:

• '#define RCAUX2PIND17' darf hier 
nicht auskommentiert werden!

• die Auflösung ist entsprechend des 
verwendeten Senders (1024 = 10-Bit 
oder 2048 = 11-Bit)  einzustellen

Das nachstehende Beispiel wird mit einer 
Spektrum DX8 mit DSMX Satellit und 22ms 
Pulsrate verwendet.

Please notice:

• '#define RCAUX2PIND17' must'nt be 
un-commended

• you need to adjust the resolution 
dependent to your transmitter (1024 = 
10-Bit or 2048 = 11-Bit)

The example below is used with a DX8, bound 
to a DSMX satellite with a pulsrate of 22ms.

Spektrum Satellit mit 11-Bit Auflösung | Spektrum satellite with 11-Bit resolution



3.  Layout und Maße | Layout and Dimensions



4.  Externe Sensoren und optionales Zubehör  | 
External sensors and optional features

 4.1.  Externes  I²C-Interface | External  I²C-Interface

Es können alle von der Software 
unterstützten I²C Sensoren angeschlossen 
werden.
Da GYRO, ACC, MAG und BARO schon 
vorhanden sind, empfiehlt sich nur noch der 
Anschluss eines externen I²C GPS Moduls.

ACHTUNG:
Der externe  I²C-Bus des microWii ist für 
3.3V Sensoren!

You may connect any I²C sensor to the 
microWii that is supported by the software.

But as GYRO, ACC, MAG and BARO were 
present on the microWii the only addition 
might be an external I²C GPS-module.

ATTENTION:
The external  I²C bus of the microWii may 
only be used with 3.3V sensors!

I2C-Interface für externe Sensoren (3.3V Logikpegel) | I2C-interface for external sensors (3.3V 
logic level)



 4.2.  LED-Treiber für LED-Stripes | LED-driver for LED-
Stripes

Auf der Unterseite des microWii kann ein 
LED-Treiber 'U10' sowie die Buchse 
'LEDOUT' nachbestückt werden. Diese 
Bauteile ermöglichen es – zusammen mit 
einer Ergänzung im MultiWii-Sketch – den 
Flugzustand mittels LED-Stripes 
anzuzeigen. 

Daten des LED-Treibers 'U10':
Hersteller: ON-Semiconductor
Teile-Nr.: CAT4104V-GT3
Digikey-Nr.: CAT4104V-GT3OSTR-ND

Daten des 'LEDOUT' Steckverbinders:
Hersteller: JST
Produkt: PH-Series
Teile-Nr.: S2B-PH-SM4-TB(LF)(SN)
Digikey-Nr.: 455-1749-1-ND

Löten Sie die Bauteile auf die Unterseite der 
Platine. Achten Sie auf richtige Orientierung 
von 'U10'. Sichern Sie die 'LEDOUT'-Buchse 
ggf. zusätzlich mit etwas Sekundenkleber.  

The bottom of the microWii gives you the 
possibility to mount an LED-driver 'U10' and 
a connector 'LEDOUT'. Those components – 
together with an addition to the MultiWii-
Sketch – allows to signalize the flight 
condition of your multicopter via LED-
Stripes.

Details of the LED-driver 'U10':
Manufacturer: ON-Semiconductor
Part-no: CAT4104V-GT3
Digikey-no.: CAT4104V-GT3OSTR-ND

Details of the connector 'LEDOUT':
Manufacturer: JST
Product: PH-Series
Part-no.: S2B-PH-SM4-TB(LF)(SN)
Digikey-no.: 455-1749-1-ND

Solder the components in place on the 
bottom of the microWii-PCB. Please observe 
for correct orientation of 'U10'. Apply some 
superglue to 'LEDOUT' if needed.

Orientierung von U10 | Orientation of U10

JST S2B-PH-SM4-
TB(LF)(SN)



LED-Treiber - an LEDOUT wird die Kathode der LED-Stripes 
angeschlossen | LED-driver - connect the cathode of the LED-stripes to 
LEDOUT

microWii mit montiertem LED-Treiber, Spektrum Buchse und 
eingeschaltetem 3S-LiPo Spannungsteiler | microWii populated with LED-
driver, Spektrum connector and 3S-LiPo voltage divider enabled



 4.2.1.  Funktionsbeschreibung LED-Treiber | functional 
description of the LED-driver

Der CAT4104 ('U10') ist ein LED-Treiber der 
so eingestellt wurde dass er 600mA Strom 
liefern kann.
Der Treiber arbeitet als Stromsenke, weshalb 
an den 'LEDOUT'-Anschluss die Kathoden 
(Minus-Pol) der LED-Stripes angeschlossen 
werden müssen.
Die Schaltung in der Abbildung ist lediglich 
ein Vorschlag. Bei dieser Schaltung ist die 
Grundfarbe von Strip A grün während Strip B 
rot leuchtet nachdem der LiPo angeschlossen 
wurde. Über den LED-Treiber wird nun eine 
andere Farbe (rot bzw. blau) 'beigemischt'.

The CAT4104 ('U10') is a LED-driver that is 
configured to supply 600mA.

The driver is working as a current sink, 
that's why you need to connect the 
cathodes (negative terminal) of your LED-
stripes to 'LEDOUT'-connector.
The schematic shown above is only acting 
as an example. With this wiring strip A will 
light up green and strip B will light up red 
once the LiPos is connected. The LED-
driver now mixes a second colour into (red 
respectively blue).

RGB LED-Strip am LEDOUT anschließen | connecting a RGB LED-strip to LEDOUT



Es sind zwei Ansteuervarianten für 'U10' 
vorgesehen:

• statisch, als 'STATUS-LED' analog zur 
On-Board 'STATUS-LED'

• dynamisch, über PWM durch das 
'CAM-T' Signal (Anschluss D12) 
angesteuert

Wird 'U10' durch eine PWM angesteuert 
können – je nach Duty-Cyle der PWM – 
unterschiedliche Farben dargestellt werden. 
Somit kann das microWii z.B. den jeweiligen 
Flugzustand durch ein andere Farbe 
anzeigen. 

Die Auswahl der Ansteuerung erfolgt über 
den Lötjumper 'JP4' auf der Oberseite des 
Boards. 
Die möglichen Betriebsarten sind:

• offen: 'LEDOUT' ohne Funktion
• 1-2 verbunden: statisch
• 2-3 verbunden: dynamisch

Damit der LED-Treiber genutzt werden kann 
sind auch Änderungen/Ergänzungen im 
Sketch notwendig.

The are two possible modes of operation 
for 'U10':

• static, as 'STATUS-LED' like the 
onboard 'STATUS-LED'

• dynamically, via PWM from the 
'CAM-T' signal (connector D12)

You will get different mixed colours when 
driving 'U10' dynamically via PWM – 
dependant on the duty cycle of your PWM. 
Because of that it is possible to use the 
microWii for signalizing different flight 
modes by different colour schemes.

The operation mode is selected with the 
solder-jumper 'JP4' on the TOP-Side of the 
PCB.
The selectable operation modes are:

• open: 'LEDOUT' has no function 
• 1-2 connected (soldered): static
• 2-3 connected (soldered): 

dynamically

You need to make some changes/additions 
to the multiWii-sketch in order to make use 
of the LED-driver.

 4.2.2.  LED-Treiber Software | LED-driver software

ACHTUNG:
WIRD DIE STATISCHE FUNKTIONSWEISE 
GEWÄHLT, SO IST KEINE ÄNDERUNG IM 
SKETCH NOTWENDIG!

ATTENTION:
NO MODIFICATION OF THE SKETCH IS 
NEEDED WHEN YOU CHOOSE TO USE THE 
STATIC DRIVE METHOD.



5.  Technische Details | Technical Details

Power Input:
• LiPo 2-3S (5-12,6V)

Power Output:
• - VCC 5V max. 100mA
• - 3,3V max. 100mA

Prozessor:
• Atmel ATMEGA32U4-MU
• 16Mhz
• 32 kB Flash
• 2.5 kB SRAM
• 1kB EEPROM
• Datenblatt | data sheet: http://www.atmel.com/Images/doc7766.pdf 

Gyro & ACC:
InvenSense MPU-6050
Datenblatt | data sheet:
http://www.invensense.com/mems/gyro/documents/PS-MPU-6000A.pdf 

MAG:
Honeywell HMC5883L-TR
Datenblatt | data sheet:
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-
documents/Defense_Brochures-documents/HMC5883L_3-
Axis_Digital_Compass_IC.pdf 

BARO:
Measurement Specialities MS5611-01BA
Datenblatt | data sheet:
http://www.meas-spec.com/product/t_product.aspx?id=8501

USB Anschluss:
Mini USB

The Spektrum brand is a trademark of Horizon Hobbies USA. 

http://www.meas-spec.com/product/t_product.aspx?id=8501
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www51.honeywell.com/aero/common/documents/myaerospacecatalog-documents/Defense_Brochures-documents/HMC5883L_3-Axis_Digital_Compass_IC.pdf
http://www.invensense.com/mems/gyro/documents/PS-MPU-6000A.pdf
http://www.atmel.com/Images/doc7766.pdf


6.  Anlage | Appendix

 6.1.  Schaltplan | Schematics

 6.2.  Bootloader programmieren | Flashing the Bootloader

Auf der Unterseite des microWii befindet sich 
ein 6-poliger ISP-Anschluss. Über diesen 
kann der ATMEGA32U4 mit einem 
Programmiergerät oder JTAG-ICE 
programmiert bzw. zum Code-debugging 
genutzt werden.

Der Anschluss kann aber auch dazu genutzt 
werden um einen neuen Bootloader zu 
programmieren - wenn es zukünftig einen 
geben sollte.

a) benötigtes Zubehör
• einen weiteren Arduino (ProMini, 

Nano, UNO, Duemilanove, Mega, …). 
Achtung! Beim Mega weichen die 
Pinnamen von den nachfolgend 
genannten ab.

• ein paar Litzen o-ä. und einen 
Lötkolben

b) Wie im Bild dargestellt verdrahten

c) Den neuen Bootloader laden
Dieser wird z.b. im Forum oder auf 
flyduino.com bereitgestellt sobald es eine 
neue Version geben sollte.
Entpacken Sie das .ZIP-File und kopieren Sie 
das .HEX-File in den Ordner 
Arduino1.0.1/hardware/arduino/bootloaders/
caterina 
Die bestehende Datei muss überschreiben 
werden!

Alle ausgelieferten Boards haben den 
aktuellsten Bootloader! 

The bottom of the microWii features a 6-
pin ISP footprint. This can be used fot 
programming the ATMEGA32U4 with an 
ISP-programmer or for programming or 
code debugging with a JTAG-ICE.

You can use this connector for flashing a 
new bootloader too – if the need arose in 
the future.

a) equipment needed
another Arduino (ProMini, Nano, UNO, 
Duemilanove, Mega, …)
Please notice that the Mega uses diferent 
pinnames than those mentioned below.
A few jump wires i.e. and a soldering iron

b) wire the boards as pictured

c) flashing the new bootloader
The bootloader will be available on 
flyduino.com or in the forum once a new 
version is available.
Download the .ZIP-file and copy the 
enclosed .HEX-file into the folder 
Arduino1.0.1/hardware/arduino/bootloader
s/caterina
You must overwrite the existing file!

All microWii boards were flashed with the 
latest bootloader!



d) Arduino zum ISP-Programmer machen
• verbinden Sie  den Arduino (nicht das 

microWii!) wie gewohnt mittels FTDI 
mit Ihrem PC

• öffnen Sie Arduino 1.0.1 (oder neuer)
• wählen Sie den COM-Port des FTDI 

und das richtige Arduino-Board aus
• gehen Sie auf Datei -> Beispiele -> 

ArduinoISP

• den ArduinoISP-Sketch auf den 
Arduino laden

Ihr Arduino kann jetzt als ISP-Programmer 
für die Atmel AVR  Mikrokontroller genutzt 
werden!

e) Bootloader programmieren
• Überprüfen Sie nochmals die 

Verkabelung (siehe Bild)
• Klicken Sie auf Tools -> Board -> 

Arduino Leonardo
Der Leonardo (also das microWii) 
muss als Board ausgewählt sein da 
Sie bei diesem Board den Bootloader 
neu programmieren möchten.

• Klicken Sie auf Tools -> Programmer 
-> Arduino as ISP
Damit teilen Sie der IDE mit, dass Sie 
als 'Programmiergerät' einen Arduino 
verwenden 

• Klicken Sie auf Tools -> Bootloader 
Installieren

Der Vorgang dauert einen Moment. Wenn er 
beendet ist verfügt Ihr microWii über den 
neuen Bootloader.

Anmerkung:
Es kommt vor, das Sie beim ersten Versuch 
die Fehlermeldung "...not in sync..." 
erhalten. Versuchen Sie den Vorgang dann 
einfach nochmals (Tools -> Bootloader 
Installieren).
Wenn es es nach mehreren Versuchen 
immer noch nicht geht kann es helfen, die 
Arduino IDE sowie Ihr Arduino-Board (als 
den ISP-Programmer) neu zu starten. Wenn 
die Programmierung dann immer noch nicht 
funktioniert ist mit hoher Wahrscheinlichkeit 

d) Using the Arduino as ISP-Programmer
• connect your Arduino (not your 

microWii) via FTDI-adapter to your 
PC

• open Arduino 1.0.1 (or later)
• select the COM-Port of your FTDI-

adapter and the right Arduino-Board
• click on File -> Examples -> 

ArduinoISP

• download the ArduinoISP-Sketch to 
your Arduino-Board

Now your Arduino is ready for use as an 
ISP-Programmer for Atmel AVR 
microcontrollers!

e) flashing the new bootloader
• Check all wires (refer to picture 

below)
• Click on Tools -> Board -> Arduino 

Leonardo
You need to select the Leaonardo 
(that meens your microWii) here 
since you want to flash a new 
bootloader to it

• Click on  Tools -> Programmer -> 
Arduino as ISP
This configures the IDE for use with 
an Arduino that is programmed with 
the ArduinoISP-Sketch

• Click on  Tools -> Install Bootloader

Flashing the bootloader takes a few 
moments. Once finished your microWii 
features the latest bootloader.

Remarks:
It is possible that you get an error 
message "...not in sync..." . In this case 
please retry flashing the bootloader (Tools 
-> Install Bootloader).

If flashing fails after several attempts one 
possible solution is to power-cycle your 
Arduino-Board (the one you're using as an 
ISP-Programmer) and to restart the 
Arduino IDE. If flashing still fails you 
should check your wiring again and restart 



eine Leitung falsch verbunden. Überprüfen 
Sie bitte die Verkabelung und wiederholen 
sie gegebenenfalls den Vorgang.

the process.

ProMini als ISP-Programmer | Using a ProMini as ISP-Programmer (picture credit to Felix 
Niessen, aka ronco)



 6.3.  4S-LiPo Modifikation | 4S-LiPo modification

Das microWii ist nur für den Betrieb mit 2S- 
bis 3S-LiPos spezifiziert. 
Nachstehend finden Sie Informationen wie 
Sie Ihr microWii für den sicheren Betrieb an 
4S-LiPos modifizieren können.

ACHTUNG! 
DER NACHSTEHEND GEZEIGT UMBAU 
ERFOLGT AUF EIGENE VERANTWORTUNG!

ALLE SPANNUNGSQUELLEN (LiPo, UBEC, 
REGLER, ..) UNBEDINGT ABKLEMMEN! 

a) benötigtes Zubehör
• Skalpell oder ähnlich Scharfe Klinge 

(z.B. Rasierklinge)
• ein Stückchen isolierten Draht
• externes 5V UBEC (im Lieferumfang 

des microWii enthalten; muss nach 
dem Umbau an 'X3' angeschlossen 
werden)

b) Beschreibung des Umbaus
Der Umbau schaltet den On-Board 5V Regler 
'U3' dauerhaft ab indem 3 Leiterbahnen auf 
der microWii-Platine unterbrochen 
(durchgeschnitten) werden (die drei Schnitte 
sind im Bild als Doppellinien dargestellt -> 
lieber 2x an jedem Anschluss schneiden!).

Dann wird eine Drahtbrücke – wie im Bild 
dargestellt - von C3 auf C1 – gelötet. Bitte 
darauf achten dass ein isolierter Draht 
verwendet wird! Dadurch werden die 5V des 
UBEC (an 'X3' angeschlossen) als 
Eingangsspannung für den 3.3V Regler 'U4' 
verwendet. Durch die niedrigere 
Eingangsspannung ist die Verlustleistung im 
Regler 'U4' geringer und ein 4S-Betrieb 
problemlos möglich.

c) Überprüfung des Umbaus
Um sicherzustellen dass die Leiterbahnen 
richtig durchtrennt worden sind unbedingt 
mit einen Widerstandsmesser vom Plus-
Anschluss des 'X5' (+ des LiPo2S-4S) gegen 
die beiden Anschlüsse von U3 messen.

HIER DARF KEINE VERBINDUNG MEHR 
BESTEHEN!!!!

The microWii is rated for use with 2S-3S 
LiPos.
This chapter will give you some information 
on how to modify your microWii for save 
use with 4S-LiPos.

ATTENTION!
THIS MODIFICATION IS AT YOUR OWN 
RISK!

YOU NEED TO ENSURE THAT ALL VOLTAGE 
SOURCES (LiPo, UBEC, ESC, ..) WERE 
DISCONNECTED!

a) equipment needed
• Scalpel or comparable sharp knife 

(i.e. razor blade)
• a small piece of isolated wire
• external 5V UBEC (within the cope 

of supply; needs to be connected to 
'X3' when the modification was 
made)

b) description of the modification
This modification permanently disconnects 
the on-board 5V LDO 'U3' by severing 3 
traces on the microWii-PCB (the cuttings 
were shown on the illustration by double 
lines)

Solder the wire as shown from C3 to C1. 
Please ensure to use an isolated piece of 
wire! Now the 5V coming from the UBEC 
(connected to 'X3')serves as input voltage 
for the 3.3V LDO 'U4'. The power 
dissipation of 'U4' is now less because of 
the lower input voltage. This will allow save 
operation with 4S-LiPos.

c) Inspecting the modification
To ensure that the traces were 
disconnected use your ohmmeter and 
measure the resistance between the '+' pin 
of 'X5' and the two lower pins of U3.

THERE MUST BE NO CONNECTON HERE – 
THUS THE RESISTANCE IS INFINITE!



Nochmals prüfen dass keine Kurzschlüsse 
entstanden sind (z.B. durch Lötzinn). 
Dann den UBEC wieder an 'X3' anschließen 
und mit einer Spannungsquelle (idealerweise 
einem Netzteil mit Strombegrenzung) 
verbinden. Mit einem Multimeter überpüfen 
ob die 5V vorhanden sind (z.B. an den 
Empfänger-Anschlüssen). Dann mit dem 
Multimeter nachmessen ob die 3.3V 
vorhanden sind (z.B. am 'I2CEXTLV' - dem 
externen I2C-Interface). 
Sind beide Spannungen vorhanden kann der 
Multicopter wieder/weiter montiert werden. 

Ihr microWii kann künftig mit einem LiPo 
>3S betreiben werden, nur limitiert durch 
den Eingangsspannungsbereich des externen 
UBEC.

Der LiPo-Anschluss 'X5' kann nach dem hier 
gezeigten Umbau immer noch für die LiPo-
Überwachung bis 4S genutzt werden 
(Spannungsteiler einschalten).

Re-check your soldering for shorts (i.e. by 
solder).
Now connect the UBEC to 'X3' and connect 
it to a voltage supply (a current limited 
powersupply would be best). Use your 
multimeter and check the 5V supply (i.e. 
on the RX-connector). Now check the 3.3V 
supply (i.e. on the 'I2CEXTLV'-connector – 
the external I2C interface).

If both voltages were o.k. You can start to 
re-/assemble your multicopter again.

Now your microWii is save for operation 
with LiPos > 3S, only limited by the supply 
voltage range of the external UBEC.

The LiPo-connector 'X5' can still be used for 
monitoring the LiPo-voltage up to 4S 
(remember to activate the corresponding 
voltage divider). 

microWii 4S-LiPo Umbau | microWii 4S-LiPo modification



Vorbehalt  |  Disclaimer:

Dieses Dokument wurde als Referenz fuer das 
“microWii” erstellt, und erhebt keinerlei Anspruch 
auf Korrektheit und/oder Vollständigkeit.  Beim 
Umgang mit elektrischen und elektronischen 
Bauelementen sollten stets die ensprechenden 
Vorsichtsmassnahmen getroffen werden. 

Die MultiWii Software wurde unter the GPL 
veröffentlicht.

This is a reference document for the 'microWii' 
flight controller and does not claim to be correct 
nor complete. When handling electrical or 
electronic components please always use safe 
practices. 

The MultiWii software was released under the GPL 
license.

Revisions:
v0.1: initial release based on the nanoWii manual – WORK IN PROGRESS!!
v0.2: updated and reviewed edition – 08/27/12
v0.3: updated revision – for internal use only
v0.4: information on LED-driver added – 09/03/12
v0.5: added some notes on multiWii-Sketch configuration for use with microWii
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